`

hdu 1690 Bus System(简单的最短路问题)

阅读更多

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2724    Accepted Submission(s): 677

Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.

Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

 

Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4

 

Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 

              题目大意:先给你好几段距离分别要收多少费用,超过某段距离就不能行走,然后再给你很多个点。问:给你任意两个点,这两个点要达到最少费用是多少? 由于是任意两点,那么用floyd最好。

需要注意:距离范围很大,INF要很大才行,要用到long long,写的时候要加上LL。

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1690

代码:

#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <cmath>
using namespace std;

const long long INF = 99999999999LL;    //注意!要加LL,不然会报错数据太大
const int N = 105;

int l1, l2, l3, l4, c1, c2, c3, c4;
long long map[N][N];    //距离可能会爆int,所以用long long
int place[N];
int n, m;

void init()
{
    int i, j;
    for(i = 1; i <= n; i++)
        for(j = 1; j <= n; j++)
            if(i == j) map[i][j] = 0;
            else map[i][j] = INF;
}

void input()
{
    int i, j, len;
    scanf("%d%d%d%d%d%d%d%d", &l1, &l2, &l3, &l4, &c1, &c2, &c3, &c4);
    scanf("%d %d", &n, &m);
    init();
    for(i = 1; i <= n; i++)
    {
        scanf("%d", &place[i]);
    }
    for(i = 1; i <= n; i++)
    {
        for(j = i+1; j <= n; j++)
        {
            len = abs(place[i] - place[j]);
            if(0 < len && len <= l1) map[i][j] = map[j][i] = c1;
            else if(l1 < len && len <= l2) map[i][j] = map[j][i] = c2;
            else if(l2 < len && len <= l3) map[i][j] = map[j][i] = c3;
            else if(l3 < len && len <= l4) map[i][j] = map[j][i] = c4;
        }
    }
}

void floyd()    //这题绝对是用floyd方便
{
    int i, j, k;
    for(k = 1; k <= n; k++)
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                if(map[i][j] > map[i][k] + map[k][j])
                     map[i][j] = map[i][k] + map[k][j];
}

void output()
{
    int ti, tj;
    static int zz = 1;
    printf("Case %d:\n", zz++);
    while(m--)
    {
        scanf("%d %d", &ti, &tj);
        if(map[ti][tj] != INF)
            printf("The minimum cost between station %d and station %d is %I64d.\n", ti, tj, map[ti][tj]);
        else
            printf("Station %d and station %d are not attainable.\n", ti, tj);
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        input();
        floyd();
        output();
    }

    return 0;
}

 

0
9
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics