`

hdu 2923 Einbahnstrasse(映射+floyd:注意重边!)

阅读更多

Einbahnstrasse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 783    Accepted Submission(s): 209

Problem Description
Einbahnstra e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.

 

Input
Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:

A -v -> B
A <-v - B
A <-v -> B

A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.

 

Output
For each test case, print the total distance traveled using the following format:

k . V

Where k is test case number (starting at 1,) is a space, and V is the result.
Sample Input
4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0

 

Sample Output
1. 80
             题目大意:给你一个起点,再给你有破车的城市,城市可能会重复(有多部破车),然后要求过去一部一部拉回起点,问全部拉回去的最短距离是多少?
需要注意以下几点:
1.输入的是城市,用映射更加方便;
2.城市可能重复,题目数据中可以看出;
3.输入需要注意,路是有方向的,用cin比较方便判断<和>;
4.可能有重边!!!选择短的那条路。
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <string>
#include <map>
using namespace std;

const int INF = 99999999;
const int N = 105;

map<string, int> mp;    //映射:城市->点
map<string, bool> bp;    //映射:城市是否出现过
int way[N][N], num[N];  //num[]标记该城市要推车的数量
int n, d, m, c;

void init()     //初始化函数
{
    int i, j;
    mp.clear();
    bp.clear();
    for(i = 1; i <= n; i++) num[i] = 0;
    for(i = 1; i <= n; i++)
        for(j = 1; j <= n; j++)
            if(i == j) way[i][j] = 0;
            else way[i][j] = INF;
}

void input()    //输入函数
{
    int i, ti, tj, cost, ans = 1;   //ans为城市点标记
    string str1, str2;
    char sh1, sh2, ch;
    cin >> str1;        //先输入起点并标记
    mp[str1] = ans++;
    bp[str1] = true;
    for(i = 1; i <= d; i++)
    {
        cin >> str1;
        if(!bp[str1])
        {
            mp[str1] = ans++;
            bp[str1] = true;
        }
        num[ mp[str1] ]++;  //该城市要推车的数量++
    }
    c = ans;    //c为标记需要推车的城市数量
    for(i = 1; i <= m; i++)
    {
        //用cin输入比较方便判断:sh1、sh2是方向
        cin >> str1 >> sh1 >> ch >> cost >> ch >> sh2 >>str2;
        if(!bp[str1])
        {
            mp[str1] = ans++;
            bp[str1] = true;
        }
        if(!bp[str2])
        {
            mp[str2] = ans++;
            bp[str2] = true;
        }
        ti = mp[str1];
        tj = mp[str2];
        //注意!可能会有重边,若有则要短的那条
        if(sh1 == '<')
            if(cost < way[tj][ti])
                way[tj][ti] = cost;
        if(sh2 == '>')
            if(cost < way[ti][tj])
                way[ti][tj] = cost;
    }
}

void floyd()    //这题绝对是用floyd求最短路
{
    int i, j, k;
    for(k = 1; k <= n; k++)
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                if(way[i][j] > way[i][k] + way[k][j])
                    way[i][j] = way[i][k] + way[k][j];
}

int main()
{
    int i, sum, zz = 1;
    while(scanf("%d %d %d", &n, &d, &m))
    {
        if(!n && !d && !m) break;
        init();
        input();
        floyd();
        sum = 0;
        for(i = 2; i < c; i++)
        {
            //来回最短距离*推车数量
            sum += (way[1][i] + way[i][1])*num[i];
        }
        printf("%d. %d\n", zz++, sum);
    }

    return 0;
}
 
0
10
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics