`

hdu 2588 GCD

阅读更多

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 405    Accepted Submission(s): 172

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

 

Output
For each test case,output the answer on a single line.

 

Sample Input
3 1 1 10 2 10000 72

 

Sample Output
1 6 260
 
           题目大意: 给你N和M,求满足1<=X<=N,(X,N)>=M中 x的个数。
思路:要用到欧拉函数,还要算出N的约数,eular(N/约数)且约数>=M就是其中一个数的和。刚好就是,自己推一下就知道。
代码:
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

int a[100005];
int cnt;

int eular(int n)
{
    int i, ans = n;
    for(i = 2; i*i <= n; i++)
    {
        if(n%i == 0)
        {
            ans -= ans/i;
            while(n%i == 0)
                n /= i;
        }
    }
    if(n > 1) ans -= ans/n;

    return ans;
}

void init(int n)    //找出n的约数并保存于数组a中
{
    int i;
    cnt = 0;
    for(i = 1; i*i < n; i++)
    {
        if(n%i == 0)
        {
            a[cnt++] = i;
            a[cnt++] = n/i;
        }
    }
    if(n%i == 0) a[cnt++] = i;
    sort(a, a+cnt);
}

int main()
{
    int i, t, n, m, sum;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %d", &n, &m);
        init(n);
        sum = 0;
        for(i = 0; i < cnt; i++)
        {
            if(a[i] >= m)
            {
                sum += eular(n/a[i]); //总和就是各个eular(n/a[i])的和
            }
        }
        printf("%d\n", sum);
    }

    return 0;
}
 
 
0
0
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics