`

hdu 2577 How to Type(很爽很好玩的DP)

阅读更多

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 842    Accepted Submission(s): 364

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.

 

Sample Input
3 Pirates HDUacm HDUACM

 

Sample Output
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 
            题目大意:给你一个字符串,问要至少按多少次键盘才能打出这些字母,有大写和小写,可以按caps lock,也可以按shift。注意!!最后打完后,caps lock一定要是关灯的(小写)。
         一道很好的DP题目!非常好!用on[]记住开灯的状态,用off[]记住关灯的状态,然后根据大小写字母来写状态转移方程!下面代码有详细注释。
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;

char ch[105];
int on[105];    //打开大写
int off[105];   //关闭大写

int main()
{
    int i, t, len;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s", ch);
        len = strlen(ch);
        off[0] = 0; //刚开始的没开灯
        on[0] = 1;  //开灯的要+1
        for(i = 0; i < len; i++)
        {
            if(ch[i] >= 'a' && ch[i] <= 'z')    //小写字母
            {
                //开:(开~~shift+type, 关~~type+开灯)
                on[i+1] = min(on[i] + 2, off[i] + 2);
                //关:(开~~lock+type, 关~~type)
                off[i+1] = min(on[i] + 2, off[i] + 1);
            }
            else    //大写字母
            {
                //开:(开~~type, 关~~开灯+type)
                on[i+1] = min(on[i] + 1, off[i] + 2);
                //关:(开~~lock+type, 关~~shift+type)
                off[i+1] = min(on[i] + 2, off[i] + 2);
            }
        }
        on[len]++;
        printf("%d\n", min(on[len], off[len]));
    }

    return 0;
}
 
0
2
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics