`

hdu 1068 Girls and Boys(二分图求最大独立集合)

阅读更多

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3260    Accepted Submission(s): 1405

Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

 

Sample Output
5 2
            题目大意:给你每个人互相认识的人,然后问最多能找到多少个人都互不认识。其实就是找:最大独立集合!
已知:二分图最大独立集合 = 节点数 - 最大匹配数
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;

const int N = 1005;

int pre[N];
bool map[N][N], flag[N];
int n;

int find(int cur)   //匈牙利算法
{
    int i;
    for(i = 0; i < n; i++)
    {
        if(map[cur][i] && !flag[i])
        {
            flag[i] = true;
            if(pre[i] == -1 || find(pre[i]))
            {
                pre[i] = cur;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i, j, r, k, num, sum;
    while(scanf("%d", &n) != EOF)
    {
        memset(map, false, sizeof(map));
        memset(pre, -1, sizeof(pre));
        for(i = 0; i < n ; i++)
        {
            scanf("%d: (%d)", &k, &num);    //输入格式注意!
            for(j = 0; j < num; j++)
            {
                scanf("%d", &r);
                map[k][r] = true;   //建表时
            }
        }
        sum = 0;
        for(i = 0; i < n; i++)
        {
            memset(flag, false, sizeof(flag));
            sum += find(i);
        }
        sum /= 2;   //二分图具有对称性,最大匹配数 /= 2
        //二分图最大独立集合 = 节点数 - 最大匹配数
        printf("%d\n", n - sum);
    }

    return 0;
}
 
0
5
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics