`

hdu 1023 Train Problem II(大数卡特兰数-出栈次序问题)

阅读更多

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2111    Accepted Submission(s): 1238

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.

 

Sample Input
1 2 3 10

 

Sample Output
1 2 5 16796
          这题的意思就是和那个经典的出栈次序问题一模一样,就是卡特兰数,不过它的N的范围很大,肯定要用到高精度,就是大数了,直接套大数模板来求卡特兰数。就是一道经典的卡特兰数问题。
代码:
#include <iostream>
#include <stdio.h>
#include <cmath>
using namespace std;

int a[105][105];    //大数卡特兰数
int b[105];         //卡特兰数的长度

void catalan()  //求卡特兰数
{
    int i, j, len, carry, temp;
    a[1][0] = b[1] = 1;
    len = 1;
    for(i = 2; i <= 100; i++)
    {
        for(j = 0; j < len; j++)    //乘法
            a[i][j] = a[i-1][j]*(4*(i-1)+2);
        carry = 0;
        for(j = 0; j < len; j++)    //处理相乘结果
        {
            temp = a[i][j] + carry;
            a[i][j] = temp % 10;
            carry = temp / 10;
        }
        while(carry)    //进位处理
        {
            a[i][len++] = carry % 10;
            carry /= 10;
        }
        carry = 0;
        for(j = len-1; j >= 0; j--) //除法
        {
            temp = carry*10 + a[i][j];
            a[i][j] = temp/(i+1);
            carry = temp%(i+1);
        }
        while(!a[i][len-1])     //高位零处理
            len --;
        b[i] = len;
    }
}

int main()
{
    int i, n;
    catalan();
    while(scanf("%d", &n) != EOF)
    {
        for(i = b[n]-1; i>=0; i--)
        {
            printf("%d", a[n][i]);
        }
        printf("\n");
    }

    return 0;
}
 
0
4
分享到:
评论
1 楼 基德KID.1412 2011-08-11  
踩!!!!!!!!!!!!!!!!!

相关推荐

Global site tag (gtag.js) - Google Analytics