`

hdu 1541 Stars(最基础的树状数组)

阅读更多

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1287    Accepted Submission(s): 503

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5 1 1 5 1 7 1 3 3 5 5

 

Sample Output
1 2 1 1 0
    
       题目大意:y递增,y不变x递增的顺序给出点你,这些点的左下方的点数代表这个点的级数,问0~N-1的级数有多少个?此题典型的数组数组,边加入点边更新点,用树状数组有很神奇的效果。
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <cmath>
using namespace std;

int n, a[32005], val[32005];

void update(int p, int k)
{
    while(p <= 32005)
    {
        a[p] += k;
        p += p&(-p);
    }
}

int sum(int x)
{
    int total = 0;
    while(x > 0)
    {
        total += a[x];
        x -= x&(-x);
    }
    return total;
}

int main()
{
    int i, x, y;
    while(scanf("%d", &n) != EOF)
    {
        memset(a, 0, sizeof(a));
        memset(val, 0, sizeof(val));
        for(i = 0; i < n; i++)
        {
            scanf("%d %d", &x, &y);
            x++;    //注意!x++的原因:如果x=0更新时就会出现死循环所以都++
            val[sum(x)]++;
            update(x, 1);
        }
        for(i = 0; i < n; i++)
        {
            printf("%d\n", val[i]);
        }
    }

    return 0;
}
 
0
3
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics